Issues with Faxing
Incident Report for Audian
Resolved
This incident has been resolved.
Posted Jul 31, 2023 - 08:00 PDT
Investigating
We are currently tracking an issue with our HIPAA Compliant eFax service vendor, and are working directly with them to find the quickest resolution possible. During this time, a subset of customers are unable to send/receive faxes. Please contact the support team at 844 611 6110 OPT 2 so that we may set you up with a temporary solution.
Posted Jul 25, 2023 - 08:41 PDT
This incident affected: Upstream Carriers.