Washington state 911 outage
Incident Report for Audian
Resolved
Centurylink is reporting that 911 services should all be restored where affected. They are still stating that they are experiencing internet outages but we are marking as resolved.
Posted Dec 28, 2018 - 14:24 PST
Update
CenturyLink posted around 8am PST that they are still working on the issue. We are still seeing indications that 911 is affected. Chairman of the FCC has indicated they will be investigating the issue as well.
Posted Dec 28, 2018 - 08:40 PST
Update
We are continuing to monitor for any further issues.
Posted Dec 27, 2018 - 23:49 PST
Monitoring
Due to the massive CenturyLink outage, 911 is currently down in Washington State. We use multiple routes but if your call does not work please utilize these alternate numbers.

Thurston County: 360-704-2740
King County:
Seattle: 206-583-2111
Eastside: 425-577-5656
South King County: 253-862-2121
Unincorporated: 206-296-3311
Posted Dec 27, 2018 - 23:38 PST
This incident affected: 911 Service.